
Varis PhotoMedia Tutorials
©2003, Lee Varis

Welcome

This tutorial has been prepared for the photographer who is striving to learn digital imag-
ing. I make an effort to supply current information about digital imaging techniques and 
general information about computer technology that is pertinent for today’s professional 
photographer. This information is based on my personal experience down in the trenches 
at the front lines of the digital revolution that is sweeping the photographic industry. 

One thing is certain: all of the information contained herein will be obsolete in a fairly 
short time - how short, I can’t say. Be forewarned that things are changing very rapidly 
and the only way to stay competitive is to keep learning. I devote a good percentage of my 
time learning new things and I am attempting to share what I learn with you but this in-
formation will go out of date so you should be flexible and not take this tutorial to be the 
ultimate statement on the subject.

I consider the knowledge contained in any of my tutorials to be public domain but the 
form in which this knowledge is presented is copyrighted as are all the photographic im-
ages used as examples. Unless otherwise noted all imagery is copyrighted by Lee Varis and 
any use of these images without permission is forbidden. You are permitted to use this 
tutorial for your personal education - you are not permitted to sell or otherwise distribute 
this material. Please contact me for any other use.

I maintain a web site where I post additional information, examples and tutorials. You are 
invited to browse various portfolios as well as download free material and purchase addi-
tional tutorials at:

http://www.varis.com

I hope you find the information contained in this tutorial helpful. Please let me know if 
you find any errors or omissions - I’m always trying to improve these materials! You may 
contact me via E-mail at:

varis@varis.com

best regards, Lee Varis 2003

http://www.varis.com


LAB Magic
secrets of the x-treme color space

Most Photoshop users have seen LAB as one of the choices of-
fered under the Image->Mode menu. Many know that LAB is the 
“connection space” used in ICC profile conversions. Most are at 
least aware that LAB is a device-independent color space. What is 
LAB good for?... Most people couldn’t begin to imagine. Even the 
published “experts” say that LAB is not an intuitive editing space 
(as if RGB or CMYK were particularly “intuitive”). LAB is there, 
fifth choice down in the list for conversion choices from the typi-
cal RGB image (Grayscale, Indexed Color, RGB, CMYK... LAB) - but 
what do you use it for?

LAB is unique in that it is the only color space choice available 
to us in Photoshop that separates luminance or lightness/darkness 
from chrominance or hue/saturation. “L” represents lightness 
where “A & B” represent hue & saturation. This feature is one rea-
son that Dan Margulis calls LAB the patron saint of lost causes. 
If there is a serious defect in an image - a major color cast, satura-
tion or strange color-crossover issues the solution often lies in LAB 
color manipulations. LAB is often a good space to do sharpening in. 
Frequently, LAB is great for solving vexing retouching issues. How-
ever, LAB is lousy for subtle, detailed color moves - its more like a 
large sledge hammer that can smash several tiny nails at once but 
if you’re not careful it can damage the wood!

We will begin our exploration of LAB with some basic observa-
tions of curve edits in LAB. We will proceed to some common uses 
and finally, end up with a fairly sophisticated correction that simu-
lates the use of flash fill in a contrasty lighting situation. You will 
see why I call LAB the X-steme color space...



Download Sample Files

Sample files for this tutorial are available for download. All 
images are copyrighted © 2003 by Lee Varis unless otherwise 
noted. Use of these files is restricted to personal education in this 
tutorial - no other use is permited. By clicking the download but-
ton below you are agreeing to these terms.

Download Files

These files are compressed in a Binhex archive. To use these 
files you must first extract them from the archive using a file 
compression utility. You can download the excellent free “Stuffit 
Expander” utility from Aladin Software by clicking below:

Stuffit Expander

Choose your platform from the buttons at the top of the web 
page -  Mac, Windows and Unix

http://www.stuffit.com/win/index.html
http://www.varis.com/StepByStep/LabMagic/LabMagicSamples.hqx


LAB Color Basics
the anatomy of LAB curve corrections

The “L” of LAB is easy to under-
stand because it behaves pretty much 
the same way as a regular grayscale 
channel. The only difference is the 
way the numbers are represented. Val-
ues go from “0” (black) to 100 (white) 
- basically there are only 100 positions 
available for a point on the curve even 
though there are 256 steps in an 8 bit 
grayscale channel. This also makes 
LAB a bit coarse for detailed edits in 
luminosity, though it still has its uses, 
as we shall see later, in blending calcu-
lations. 

The “A” channel represents the 
magenta-green color of the image. 
When the curves is set up as shown 
- with the black point to the lower 
left - moving a point up makes it 
more magenta, moving it down, more 
green. In both A & B channels the 
point at which the curve crosses the 
horizontal mid-point line represents 
neutrality in that channel. In the “A” 
channel the image would be neither 
magenta nor green at this point.

The “B” channel represents the yel-
low-blue color of the image. Moving up 
= more yellow. Moving down= more 
blue. The end points in both channels 
represent absolute (x-treme) and un-
printable values. Black starts at -128, 
green (A) or blue (B). White ends up at 
+127, magenta (A) or yellow (B). Values 
more extreme than -60 or +70 are out 
of gamut for most CMYK color spaces. 
This really leaves only about 1/3 of the 
curve in the middle as useful editing 
space. 



LAB channels in action

Lets start our exploration of LAB by ex-
amining this familiar subject. Looking at the 
individual channels reveals the nature of the 
grayscale information in each channel. 

The “L” channel looks like a decent B+W 
representation and the “A” and “B” channels 
look a bit strange, lacking in contrast. The “B” 
channel comes the closest to a normal looking 
grayscale because the image is mostly blue and 
yellow - the closer to medium gray the less 
color saturation in a given channel. We can see 
that there is very little red/magenta and green 
in this image because the “A” channel is so 
gray.

Normal color saturation is fairly gray in the A & B channels - anything close to 
white or black would be way out-of-gamut for most color spaces. Subtle shifts in gray 
value will therefore have profound effects on hue & saturation. This is both the strength 
and weakness of LAB as an editing space. Huge color moves can be made easily without 
“breaking” the image. A Hue/Saturation in RGB, if pushed too far, can result in poster-
ization. Not so with LAB... subtle moves, however, are much more difficult...  



A channel - green

If we move the whole curve, straight towards the lower right 
corner in the “A” channel the whole image will move uniformly 
towards green - much like placing a green filter over the lens...



A channel - magenta

Conversely, if we move the other way, towards the upper left cor-
ner, the image turns towards magenta. You can see the tone that 
was originally green in the leaves has now become quite red. This 
is really a fairly small move on the curve to produce such a huge 
shift in color.



A channel - gray

If we level the curve to a straight horizontal at the mid point the 
whole channel will turn gray and we’ll have no magenta or green in 
the image at all. The result is an image that is only varying satura-
tions of yellow and blue.



B channel - gray

If we instead do this with the “B” channel, all the blue and yellow 
disappears and we are left with only the muted pink and green from 
the original color. Making the curve more vertical would increase 
the saturation and color intensity of yellow and blue. This image 
was fairly saturated in yellow and blue originally but we might still 
be able to correct for more color saturation in the blue sky...



B channel - Blue Saturation

In the original image the blue sky lives in the bottom half of the 
curve. By moving that part of the curve to the right we can increase 
the saturation of the blue sky without affecting the other colors of 
the image. We don’t have to worry about “clipping” black because 
there is nothing in the image that is that saturated. In general, we 
tend to edit in LAB using simple shapes for our curves like we have 
done here. Compare this version with the original...

Click for 
original 



While it may be tempting to increase the saturation in images by 
simple curve edits in LAB, its also very easy to over do it! LAB can 
hold colors that are out-of-gamut for normal human vision. Over-
amp your colors and you could end up clipping color variation out of 
the picture and end up with flat Peter Max candy colored images.  

Click  
back



Reversing A&B Channels

If we reverse the direction of the curve in both the A & B channels 
we can invert the colors without affecting the luminosity of the im-
age. This is similar to, but much cleaner than, rotating the hue 180° 
in a Hue/Saturation adjustment layer and changing the apply mode 
to “Color” in an RGB image. Working the channels individually this 
way can get you some very effective color swapping effects.



LAB - what is it good for?

You may be thinking to yourself at this point 
that all this discussion of the LAB color space is 
well and good but... “what the heck do I use this 
for?”

Well my brothers... LAB comes to the rescue quite of-
ten with severe color casts such as the one encountered 
here. The red/yellow dim tungsten lighting has sucked 
the color out of this daylight balanced shot. In RGB 
there is very little we can do to modify the overall color. 
There is a severe red cast – the green channel is very 
dark and the blue channel is almost nonexistent! When 
faced with this kind of challenge we start by converting 
into LAB: Image-> Mode-> Lab Color.



LAB - putting the color back

Pushing the black point in the A & B channels 
to the right has dramatically altered our color 
temperature. This simple move has revealed the 
blue in the woman’s dress as well as the moonlit 
back yard beyond the tent canopy. This is not a 
simple color balance shift however because the 
color of the skin has remained as well as the 
wood parquet floor. 

This may not be the best we can do with this 
image but its a good start – a return trip into 
RGB or CMYK followed by some more subtle 
curves can take us just about anywhere that we 
care to go. I encourage you to experiment with 
hopeless images this way to see just how far you 
can push them into shape.



Special Problems
LAB solutions for tricky situations

Here is a special problem that, at first, may not seem like a candidate for LAB 
corrections. I took this grab shot with a point & shoot digital camera on full-
auto, jpeg mode. If I had been thinking I might have been able to get a better 
shot by activating the built-in flash. The lighting is terrible... the subject is in 
spotty shade and the colors are muted, the background distracting. This image 
is a challenge and normal techniques are just not going to give us much...

Click to first
correction

Click to final
version



LAB in 16 bits

Normally I’m not a big advocate of editing in 16 bit color 
space. For most images (99%) there just doesn’t seem to be a 
particular benefit to pushing around 4x the amount of data. 
LAB edits , however, can be a bit coarse in that the grayscale 
steps can be pushed outside of normal limits very easily and 
changes can happen abruptly. Also simply converting into 
LAB causes you to loose 10-20 levels of info in each chan-
nel. If your image is weak to begin with (and if it isn’t, you 
shouldn’t be considering LAB edits) it can be a good idea to 
preserve as much info as possible. 

The Bow Hunter image has Jpeg artifacts throughout that 
can get amplified through some of the edits we are going 
to make - we have to minimize them. We’re also going to 
be darkening and then lightening the image a considerable 
amount in part of our correction. These compound edits can 
cause some problems later so I think it could be wise to go 
into 16 bits for some of these moves. 

Before converting to LAB, select: Image-> Mode -> 16 Bits/
Channel. Then select: Image-> Mode-> Lab Color



Killing Jpeg artifacts

One of the curious features of LAB is that Jpeg artifacts are often not visible in 
the L channel but will show up in both the A and B  channels. We cannot see any 
evidence of Jpeg blockiness here in the “L” channel...



“A” Channel artifacts

The Jpeg “blockiness” shows up here in the “A” channel. The solution is to 
blur the channel slightly to smooth out the artifacts. The Median filter is my first 
choice for this kind of thing. This approach also works for colored noise in digital 
camera files and it can often be an automated procedure for batch processing Jpeg 
camera files...



Median Filter

A radius setting of 1 pixel works wonders to smooth 
out the artifacts. You can also use this on color alias-
ing artifacts. 



“B” Channel artifacts

Again here in the “B” channel - nasty Jpeg artifacts.



Median Clean up

After blurring, they are not visible. There is another reason for minimizing 
these artifacts in the A & B channels besides simple cosmetic obsessiveness. Later 
on we are going to do some blending operations with this image utilizing these 
channels and it will be desirable to have them as smooth as possible.



Image Correction Strategy

OK... now that we’ve gotten some preliminary 
things out of the way, it is time to develop a correc-
tion strategy for our problem image. Start by stat-
ing the problem: This is a picture of a Bow Hunter 
wearing camouflage sitting in front of a forest back-
ground - he is blending in with the background! 
This may be exactly what he wants but it does not work for our picture. Our 
challenge is to try to separate him from the background, ideally, without 
having to do extensive masking. If I was to take this picture over I would 
use flash fill to over power the spotty lighting on his face and darken the 
leaves in the background. 

I’ve told you that the key to this correction lies in LAB - let’s look at 
the LAB channels and see if we can find a clue. Our salvation is in the 
“A” channel (seen above right). This channel has the face and arms of our 
hunter lighter than everything else in the image. Now if we could somehow 
apply that lightness in a way that separates him from the background we’d 
have a head start on our correction.

This is exactly what we are going to do. Our first step is to duplicate the 
image! We’ll work on a duplicate, holding the original in reserve just in case 
we need to use something from the original in a layer in our correction. 
This is a good habit to get into especially when dealing with unusual cor-
rections that may take far afield.

Select: Image-> Duplicate... and set the original aside...



Step One:
Make everything darker & flatter

I want the background to get darker and more subdued so, for the first step, pull 
the white point in the “L” channel down and shape the curve for reduced contrast. 
The image seems very gray so, at this point, we’ll increase saturation just a little 
by pushing the white point to the left and the black point to the right in the A & B 
channels by just a few points... The next steps require moves that are not available 
in 16 bits so we have to convert to 8 bits now. 

Select: Image-> Mode-> 8 Bits/Channel

Click to next
correction

Click to original 
version



Step Two:
Apply Image: A to Lightness

This next step is easier to do than explain! We are 
going to take advantage of one of Photoshop’s little 
known but most powerful calculations. Select the 
“Lightness” channel in the Channels palette then se-
lect: Image-> Apply Image... The resulting dialog allows 
us to apply one channel against another using one of 
several apply modes. What interests us here is that the 
“A” channel has a face that is lighter and a background 
that is darker than medium gray. By using Overlay we 
can make the face lighter and the background darker 
in one step.

Apply Image has many uses. 
One of its advantages is that image 
calculations made this way are of-
ten better, cleaner and less prone to 
posterization than cranking curves 
on a channel directly. We are using 
image information to affect the im-
age rather than artificially re-calcu-
lating pixels in some arbitrary way. 



Apply A to Lightness

The result after two applications of the “A” channel to the “L” channel in Overlay 
mode. The image could use a little more color variation/saturation so we will next ap-
ply the “A” channel to itself in Overlay mode this will increase the contrast in the “A” 
channel thus increasing saturation and color variation. Next we will do the same for 
the “B” channel - Apply Image: B to B in Overlay – increasing saturation in yellows and 
blues.

Click to next
correction

Click to original 
version



Step Three:
Apply Image: A to A & B to B

Before entering Apply Image again make sure that you target the A chan-
nel by selecting it in the Channels palette. Here is the image after applying 
A to A in Overlay mode at 25% and B to B in Overlay at 25%

Click to next
correction

Click to original 
version



Step Four:
Restore luminosity details

At this point some of the highlights in the face 
and elsewhere have lost their sparkle. Now is the 
time to retrieve these luminosity details from our 
original version. You could paint these in from an 
earlier history state but I feel its better to keep 
your options open for later on by using a layer 
here. Simply take your original copy and drag it 
into the new version while holding the shift key. 

Make a black layer mask by clicking on the 
layer mask icon while holding the option/Alt 
key. Change the layer apply mode to Luminosity 
and selectively paint back highlight details in the 
nose, mouth, hands and some of the highlights on 
the leaves and pants. These little details make all 
the difference.  

We can do a little more fine tuning with the dodge and 
burn tools will we’re at this point in our project.



Step Five:
Dodge & Burn in the Lightness Channel

This step is not strictly necessary – I’m just 
including it here to illustrate an additional LAB 
technique. If you flatten the image now you can 
add a few subtle highlight and shadow details by 
using the Dodge and Burn Tools in the “Lightness” 
channel. Target the “L” channel by selecting it in 
the Channels palette. You can then use the Dodge 
and Burn tools to add a little more contrast into 
areas of interest. In this example I’ve added some 
shape to the hair at his temples and chin.



Click to next
correction

Click to original 
version

Step Six:
Convert to RGB and final curves

After doing all this it is finally time to return to RGB. Select: Image-> 
Mode-> RGB. Now place a Curves Adjustment layer to brighten things 
up just a little and hit target white point-black point values. OK... Almost 
done! Look at this image a bit and try to imagine what would make it 
even better...



Step Seven:
Sharpen subject and Blur Background

While its easy to get excited about how far 
we’ve come, once we look at this image carefully, 
we can see that the actual focus of the camera 
seems to be towards the back. We have to admit 
that it would really help if the subject was sharper 
than the background! 

We’ve scrupulously avoided using selections or 
masks in our corrections so far but now there’s just 
no avoiding it. We have to make a selection around 
the figure in order to apply sharpening selectively. 
In addition we will need to additional tricks to get 
a blur to happen correctly on the background. 

The rest of this tutorial is fairly straightfor-
ward, we no longer need LAB tricks and we are 
on familiar ground with RGB. This last finishing 
touch however, can separate the men and women 
from the girls and boys!

Click to see 
final effect



Make Selection

There are a couple of different ways to make this selection – I choose to 
use a path drawn with the Pen Tool. I’ve supplied this path on the sample 
along with a finished alpha channel that you can use if you’d rather skip the 
practice. At any rate, activate the selection by Cmd/option clicking the alpha 
channel - now copy the background into a new layer and...Cmd/option

click



Make Layers & Sharpen

...click on the Layer Mask icon to save the se-
lection into the layer mask. Now copy this layer 
to make a 2nd duplicate – change the apply mode 
to Luminosity. You are now ready to apply un-
sharp mask. 

I used the settings shown here you can modify 
this to suit your output conditions. The idea here 
is that the luminosity apply layer eliminates the 
possibility of colored halos that would make the 
sharpening look more artificial. 

The next step will to blur the background but 
before we run the Gaussian Blur filter there is one 
more trick to insure a realistic effect...



Clone into Edge

If we simply run the Blur now the edge of the figure will 
blur out behind the sharp figure giving a sort of blur halo 
that could ruin the effect we’re after. 

To make this work better, target the background by 
clicking on its thumbnail in the Layers palette. Then load 
the selection from the alpha channel again – Cmd/option 
click on the Alpha thumbnail in the channels palette. Se-
lect: Select-> Modify-> Expand... and expand the selection 
by 2 pixels. 

Now Clone background into the edge of the selected 
area – its easier if you turn off the visibility of the upper 
layers. We want to get the background underneath the sub-
ject edge so that when we blur the background there won’t 
be that telltale blur halo to give away the trick!



Click to see 
previous

Proper Focus Restored

Run the Gaussian Blur filter over the back-
ground until you get the desired depth of field ef-
fect. Now the Bow Hunter really separates from 
the background.



Final Version

Click to previous
version

Click to original 
version

Here is the final version. I added a slight skylight rim at his shoulder 
by painting a light blue into an overlay layer – you can see my final layers 
to the left. To finish off, I add an Overlay noise layer that gives a consis-
tent surface for the blurred and sharp areas. 

A number of techniques combined to make a silk purse out of a sows 
ear! As they say, there are no bad originals only bad Photoshop users...



Conclusion

Congratulations... if you managed to follow along you’ve learned 
some very sophisticated Photoshop techniques for resurrecting 
dead-on-arrival originals including:

• Adding saturation with steeper A & B curves in LAB

• De-saturating by flattening A & B curves

• Minimizing Jpeg artifacts by blurring A & B channels

• Fixing radical color casts with simple LAB curves

• Using Apply Image to adjust image contrast and color

• Dodging and Burning in the Lightness channel

• Separating subject and background through sharpening/blurring

You’ve also gained an understanding of the nature of LAB color 
space and perhaps seen how some of these techniques can apply 
to your own work. The real work begins now as you start to apply 
these techniques and hopefully invent some of your own. If this 
seems way too complicated be patient – return to this tutorial later 
and work through it again. Many things require more than one ex-
posure before they sink in.



Varis PhotoMedia Tutorials
©2003, Lee Varis

Thank you

I hope you enjoyed this tutorial. The techniques outlined here represent just the tip of the 
iceberg. Photoshop is a very deep application - a person could spend years studying it and 
there will always be more to learn. If all this seems a little overwhelming, take a break, do 
what you feel comfortable doing in Photoshop and return to this tutorial again later on. 
Often, it takes several weeks for a particular technique to sink in so give it time.

I have other tutorials available online (navigate to the methods section), some are free and 
some are available for a modest charge. See tutorials and some examples of my work at:

http://www.varis.com

There are many learning resourses available on the web - here are a few other sites with 
good information:
http://www.russellbrown.com http://www.creativepro.com
http://luminous-landscape.com/ http://www.imaging-resource.com/HOWTO.HTM
http://www.photoworkshop.com/ http://www.adobe.com/misc/training.html
http://studio.adobe.com/expertcenter/photoshop/
main.html

http://www.ledet.com/margulis/articles.html

http://www.steves-digicams.com/ http://www.photoshopuser.com/
http://www.handson.nu/ http://photoshopgurus.info/

These last two links are typical of the majority of Photoshop tutorial sites - they are fo-
cused on cool graphics effects not photography. You might want to look over this material 
anyway - sometimes you can learn a lot about basic functions in Photoshop.

I’m always trying to improve these materials and I’m always open to your feedback. You 
may contatct me via email at:

varis@varis.com
best regards, Lee Varis 2003

http://www.varis.com
http://www.russellbrown.com
http://www.creativepro.com
http://luminous-landscape.com/
http://www.imaging-resource.com/HOWTO.HTM
http://www.photoworkshop.com/
http://www.adobe.com/misc/training.html
http://studio.adobe.com/expertcenter/photoshop/
http://www.ledet.com/margulis/articles.html
http://www.steves-digicams.com/
http://www.photoshopuser.com/
http://www.handson.nu/
http://photoshopgurus.info/
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