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Welcome

This tutorial has been prepared for the photographer who is striving to learn digital imag-
ing. I make an effort to supply current information about digital imaging techniques and 
general information about computer technology that is pertinent for today’s professional 
photographer. This information is based on my personal experience down in the trenches 
at the front lines of the digital revolution that is sweeping the photographic industry. 

One thing is certain: all of the information contained herein will be obsolete in a fairly 
short time - how short, I can’t say. Be forewarned that things are changing very rapidly 
and the only way to stay competitive is to keep learning. I devote a good percentage of my 
time learning new things and I am attempting to share what I learn with you but this in-
formation will go out of date so you should be flexible and not take this tutorial to be the 
ultimate statement on the subject.

I consider the knowledge contained in any of my tutorials to be public domain but the 
form in which this knowledge is presented is copyrighted as are all the photographic im-
ages used as examples. Unless otherwise noted all imagery is copyrighted by Lee Varis 
and any use of these images without permission is forbidden. You are permited to use this 
tutorial for your personal education - you are not permited to sell or otherwise distribute 
this material. Please contact me for any other use.

I maintain a web site where I post additional information, examples and tutorials. You are 
invited to browse various portfolios as well as download free material and purchase addi-
tional tutorials at:

http://www.varis.com

I hope you find the information contained in this tutorial helpful. Please let me know if 
you find any errors or ommissions - I’m always trying to improve these materials! You 
may contatct me via email at:

varis@varis.com

best regards, Lee Varis 2003

http://www.varis.com


Image Distortions
using displacement maps

We see the world around us as a 3-dimensional collection of forms, shapes 
and colors arranged in space. We most often represent this vision in two di-
mensions of value and color but somehow this 2-D photo record conjures up 
the full three dimensions of our real vision. Our visual system is very good at 
deciphering visual clues to reconstruct reality. By manipulating these visual 
clues, Photoshop allows us to push and pull our images in new ways to recon-
struct realities that never existed. 

One of the most powerful methods of manipulation we have involves the 
use of one image to distort another. Photoshop accesses this under the Filter 
menu: Filter-> Distort-> Displace. Displacement maps can bend an image to 
fit the contours of another image and this comes in very handy for creating 
certain effects. Many of these effects have applications in commercial work 
though the way Photoshop presents the Displace filter it is not obvious how to 
achieve some of the easiest ones.

The follows pages will walk you through the use of the displace filter and 
provide some ideas for creating displacement maps. Like all good things in 
Photoshop, the best effects involve multiple steps and a collection of tech-
niques applied in concert. I will outline the basic concepts and progress to 
more complex applications so we can fully exploit the power of displacement 
maps in your own work!

Turn off your phone, roll up your sleeves and lets begin...



Image Distortions
conforming to a surface

Here we have an image of an embroidered 
banner. We will be using this image a little 
later on for something a little more compli-
cated - right now I want to place this bumped 
surface under the banner and I want the let-
tering to conform to the bumps. The gray 
bump image has a middle gray background 
with what appear to be circular domes pro-
truding from the surface. This illusion is 
created by the dark-to-light transitions of 
tone that define each circular bump. We can 
use this to shift the position of the pixels in 
our embroidered banner. The bump image 
will become our displacement map for the 
banner image!

First, however, we need to get the shadows and light 
of the bumps into the banner image. To do that we can 
simply use the gray bump image as an overlay layer. 
With both images open, use the move tool to drag the 
gray bumps onto the banner image. In this, carefully 
prepared, example the files are the same size so, hold 
down the “shift” key before you drag and the image will 
be registered together. Now all you have to do is change 
the layer apply mode to “Overlay”... 

drag



Overlay

Overlay
for light and shadow

An Overlay layer will lighten un-
derlying layers where it is lighter than 
medium gray and darken underlying 
layers where it is darker than medium 
gray. Used in this fashion our bumps 
image acts as a lighting map...



Here is the banner with the bumps 
Overlayed at 100%

Here we have changed the layer opac-
ity to 60% for a less pronounced look. 
You’ll notice that the bumps show 
up nicely but the embroidered letter-
ing doesn’t follow the contours of the 
bumps suggested by the lighting. This is 
where the Displace filter comes in...

The general procedure for distorting our image so that it follows 
the bumps is to select: Filter-> Distort-> Displace... set the degree 
of distortion in the resulting dialog and then open the file that you 
want to use as a displacement map...

click for displace



Displace Dialog

In this example we want to shift the let-
tering side to side to conform to the bumps 
so we will enter a value in the “Horizontal 
Scale” only. The radio buttons for the “Dis-
placement Map” and “Undefined Areas” are 
unimportant in this image because the file 
we’re using for the displacement is exactly 
the same size as the file we’re distorting. 

Once you click on “OK” you’ll be present-
ed with an open dialog - this is where you 
select the file you’ll use as a displacement 
map. Photoshop defaults to the “Displace-
ment maps” folder, inside the Plug-ins folder 
to locate the file. You can navigate anywhere 
to where you’ve saved the file but if you get 
in the habit of saving your displacement map 
files here you’ll save yourself a few steps. 

We will open the same file that we used 
for the overlay layer and this becomes the 
displacement map... 



Here is the result of our 10% Horizon-
tal displacement...

Here is a 5% Horizontal displacement 
that is perhaps a little more appro-
priate for the intensity of the bumps 
we’ve chosen for the effect.

click to return



The Mechanics of Displacement

Let’s examine how all this works. At the right we have a 
simple grid. Below it we have an image of soft white and black 
spots that we will use to distort the grid...



Single Channel Displacement

Here is the result of our displacement. This is a simple 
single channel displacement because the file that we used was 
a grayscale image that only contained light and dark informa-
tion. We can see that light areas shift pixels up and to the left 
and dark areas shift pixels down and to the right - assuming 
that we enter percentage values for both Horizontal and Verti-
cal Scale in the Displace dialog. We can imagine how a surface 
might have protruding areas that are light and receding areas 
that are dark because that follows normal lighting logic. This 
is why the bump image worked as both a lighting map and a 
displacement map.



Multi-Channel Displacement

We can also use color information to distort the grid. Using 
the different values in additional channels allows us to shift 
pixels in more than 2 directions at once. Using the image below 
we will distort the grid in 4 directions...



Here we can see that white shifts pixels up and to the left, cyan 
shifts pixels up and to the right, magenta shifts down and to the 
left and blue shifts pixels down and to the right. This is a bit more 
complicated and its also not clear how this kind of displacement 
relates to lighting direction. It seems, though, that Adobe intended 
the displace filter to be used for complex surface distortions that 
achieve a sort of shower door effect because all of the default dis-
placement maps installed with Photoshop are of the multi-channel 
type...



Shower Door Displacements

+ =

The set of default displacement maps are named with a sug-
gested percentage value like the one shown here – Pentagons 10%. 
When you use these tiny files, set the “Displacement Map” to 
“Tile” instead of “Stretch to Fit” in the dialog. This results in a sort 
of impressionistic painting sort of distortion. Cute but ultimately 
not very useful. This is as far as most people get with displacement 
maps. We are after something entirely different however...



Practical Applications

I recently had an assignment to photo-
graph a banner with a logo that was going to 
be used as a sort of “bug” (a graphic element, 
usually displayed in a corner of an ad and 
not part of the main composition) for some 
point of purchase ads for Fredericks’s of Hol-
lywood, a famous fashion store that special-
izes in sexy, exotic clothing. 

The agency had a banner made up with 
embroidered lettering - we used this earlier 
for the bump image. The problem was that it 
ended up being the wrong color and the em-
broidering process left the banner wrinkled 
and unsuitable for use in the ad. They liked 
the lettering but asked me to shoot a differ-
ent banner and composite the lettering over 
it. 

I masked the original lettering, dropped 
it onto the new banner and used a grayscale 
version of the banner shot as a lighting map 
and displacement map to create the final 
composite. The following pages break down 
my actual steps...



Shoot & Retouch
original background

The first step was to take the photographs 
and retouch them. 

A wide ribbon was used as the basis for 
a red banner. It was pinned/taped in place, 
shot digital with a Megavision S3 pro and a 
path created to knock out the background 
to white. Finally, the file was spotted, color 
corrected and a drop shadow was created in 
Photoshop.



Shoot & Retouch
original letters

The embroidered lettering was photo-
graphed for maximum texture with a strong 
side light. This require that the exposure be 
equalized in Photoshop with a gradient mask 
side to side. The letters were then masked, 
isolated and placed in a separate layer against 
a red color similar to the ribbon photograph. 
That way the lettering could be evaluated 
better. Color and contrast was adjusted and 
minor spot knocking performed.



Drag Letters
onto new banner

The Lettering was then dragged onto the 
red ribbon image using the move tool.

Then the lettering was scaled and rotated with Free 
Transform (Edit-> Free Transform) to get it positioned 
properly over the ribbon.



Drag Gray Map
over new letters

A grayscale version of the ribbon was 
created from the red channel of the im-
age. This was contrast enhanced and 
darkened somewhat so  that it could be 
used for the lighting map and the dis-
placement map. 

Special Note: any texture or grain 
in the displacement map can cause the 
displaced image to look ragged or jaggy. 
The image should be blurred  with the 
Gaussian blur filter just enough to 
smooth out all texture.

This grayscale file was then dragged 
onto the composite image and grouped 
(Layer-> Group with Previous) with the 
lettering so it would not affect the rib-
bon. Finally the layer apply mode was 
changed to Linear Light. 

Lee Varis
Once you have the grayscale "map" grouped with the layer you can experiment with the apply modes - usually the modes in the Overlay group work best. You may also need to adjust the contrast of this gray "lighting map" to get the right look. In this case I flattened the gray map image with a direct curves adjustment to get the effect I was after.



Displace Letters

The grayscale document was then saved to 
disk so it could be used as a displacement map.  
The lettering layer was selected then the displace 
filter was run: Filter-> Distort-> Displace...

A couple of different scale percentages were 
tried before finally settling on 15% in both Hori-
zontal and Vertical Scale. 

Its usually a good idea to try several varia-
tions, simply undo (Cmd/control-Z) the filter 
and redo it. Try using different values in Hori-
zontal and Vertical to see if you can come up 
with a better look.



Click to Displace



Click to Return

With just a little attention to detail very impressive 
results can be had. You can avoid the expense of creat-
ing “hero” products by using clean digital graphics and 
wrapping logos and labels around plain products.



Logo on a T-shirt

Here is another example of a fairly com-
mon request. This assignment was done as a 
favor for a friend of mine. 

John is an archery coach and he wanted to 
start a new archery club to recruit students. 
He had a logo designed and had plans to silk 
screen some T-shirts. However, he wanted to 
get some images up on a web site for his new 
club before he had the T-shirts printed. 

I took some pictures of him with one of 
his students (that’s John on the right!) All I 
had to do was change the girl’s shirt from 
lavender to white, remove the logo from 
John’s shirt and place the new logo on both 
shirts – easy!

Once you know how to use displacement 
maps impressing clients with this kind of 
thing becomes routine...



Editing the Displace Map

The photo was retouched and corrected to get 
plain white shirts on both figures - fairly straight-
forward. The trick with this image is in how you 
edit the grayscale map. Here I did a very simple 
grayscale conversion and Gaussian blurred at about 
8 pixels. The most important thing here was brush-
ing in a little more shape for the girl’s breasts. The 
cast shadow on her chest would distort the logo 
in the wrong way so I had to illustrate the shape I 
needed with a large soft brush. Remember to save 
the new grayscale document to disk!



Multiply & Displace

Next, I dragged the logo onto the im-
age re-sized and duplicated it so I could 
position the logo over both shirts. I 
then changed the layer apply mode for 
both logo layers to Multiply. The logo 
is on a white field so multiplying it 
blends it seamlessly over the white T-
shirts. Now all I needed to do was run 
the Displace filter over the logos using 
the grayscale file I created earlier.



Glass Effect

Our last example shows how displacement 
maps can be used for more complicated il-
lustrative effects. In this case and illustrated 
“map” is used to create a shattered glass ef-
fect that displaces the image and creates the 
edges and drop shadows for the glass shards.



Shadows & Highlights

D-Map Highlights Shadows Edges

The original Glass shatter image is the simple black 
and white illustration at the left. This was used as a 
starting point to generate the highlights, drop shadows 
and edges files. These variations were created by layer-
ing blurred/offset copies of the original and using differ-
ent apply modes to generate the results. All of these files 
have been sized to match the CoverGirl image. 



Original

All of the operations used to create 
the final version can be done directly 
on the original document but its still 
a good idea to duplicate the original 
background into a new layer and do the 
work on this duplicate layer.

Open the various grayscale docu-
ments of the shattered glass so that you 
have all of them open at the same time. 
The first step is to perform the image 
distortion with the Displace Filter...



Displace

Filter-> Distort-> Displace... set Hor-
izontal and Vertical Scale to 10% and 
open the “shatter.dmap” file. This pro-
duces the expected result at the right...



Highlights, Shadows &
Edges

Now all you need to do is load se-
lections from the open grayscale docu-
ments for highlights and shadows. Use 
the highlights selection to prepare a 
“curves” adjustment layer that shifts 
the color of the image. Next load the 
shadows selection and apply a “curves 
adjustment that creates the darker 
green shadow for the glass shards. 
Lastly, you can simply “shift-drag” the 
“Edges” document onto the image and 
change the apply mode to “Difference” 
– adjust the opacity to suit! The illu-
sion of glass shards is complete. 



Kai’s Wacky Maps

As a final indication of the potential of displacement maps I’ve in-
cluded some of Kai Kraus’ original KPT tips “Displacement Maps” on 
the CD. These are a collection of small multi-channel “maps” that can 
be used to create some truly extreme distortions. Mostly these “maps” 
are intended for use at large scale percentages like 100-500%. Use the 
files as “tile” Displacements to create unique “shower door” style dis-
tortions or apply them with “Stretch to Fit” to create cool “fun house 
mirror” effects! I’ve used the “Star Explosion” map (seen at right) as 
the basis for numerous slit-scan style zoom explosions, star bursts and 
super novas. I’ve also included a couple of other odd little maps that I’ve 
collected over the years - have fun with these



Conclusion

Image distortions created with the Displace filter can 
have a wide range of applications. The examples given 
here really only scratch the surface of what’s possible. 
The most obvious use in distorting an image to conform 
to a surface can be utilized a number of different ways.

 Reflections in water can be simulated using a grayscale 
version of the water image to distort the image you want 
to reflect into the surface of the water. Displacement 
maps can also be used to create unusual textures by us-
ing very small “maps” in “tile” mode. The uses are only 
limited by your imagination so stretch a little and play... 
you never know what you may discover!
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Thank you

I hope you enjoyed this tutorial. The techniques outlined here represent just the tip of the 
iceberg. Photoshop is a very deep application - a person could spend years studying it and 
there will always be more to learn. If all this seems a little overwhelming, take a break, do 
what you feel comfortable doing in Photoshop and return to this tutorial again later on. 
Often, it takes several weeks for a particular technique to sink in so give it time.

I have other tutorials available online (navigate to the methods section), some are free and 
some are available for a modest charge. See tutorials and some examples of my work at:

http://www.varis.com

There are many learning resourses available on the web - here are a few other sites with 
good information:
http://www.russellbrown.com http://www.creativepro.com
http://luminous-landscape.com/ http://www.imaging-resource.com/HOWTO.HTM
http://www.photoworkshop.com/ http://www.adobe.com/misc/training.html
http://studio.adobe.com/expertcenter/photoshop/
main.html

http://www.ledet.com/margulis/articles.html

http://www.steves-digicams.com/ http://www.photoshopuser.com/
http://www.handson.nu/ http://photoshopgurus.info/

Thes last two links are typical of the majority of Photoshop tutorial sites - they are fo-
cused on cool graphics effects not photography. You might want to look over this material 
anyway - sometimes you can learn alot about basic functions in Photoshop.

I’m always trying to improve these materials and I’m always open to your feedback. You 
may contatct me via email at:

varis@varis.com
best regards, Lee Varis 2003
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